Reflection PKI Services Manager Supported Platforms
Technical Note 2427
Last Reviewed 20-Jan-2015
Applies To
Reflection PKI Services Manager
Summary

This note lists the supported operating systems and platforms for Reflection PKI Services Manager, a separate optional add-on that provides X.509 certificate authentication services for many Attachmate products.

Note the following:

  • Support for platforms may change as Attachmate adds packages for additional platforms, or as platforms reach their end of life. This technical note will be updated to reflect these changes.
  • After installing and configuring PKI Services Manager, you should configure your installed Reflection product to use certificates for authentication and to connect to PKI Services Manager. For details, see the product user guides, which are available from their product documentation pages on the support site: http://support.attachmate.com/manuals/.

This technical note includes the following topics:

Supported Windows Platforms

The following Windows systems and hardware are supported by Reflection PKI Services Manager 1.0 or higher:

Platform
PKI 1.0 – 1.1
PKI 1.2
PKI 1.2 SP1 – SP2
PKI 1.3
PKI 1.3 SP1
Microsoft Windows Server 2012 R2 on Intel or equivalent, 64-bit
No
No
No
No
Yes
Microsoft Windows Server 2012 on Intel or equivalent, 64-bit
No
No
No
Yes
Yes
Microsoft Windows Server 2008 on Intel or equivalent, 64- or 32-bit
Yes
Yes
Yes
Yes
Yes
Microsoft Windows Server 2008 R2 on Intel or equivalent, 64-bit
No
No
Yes
Yes
Yes
Microsoft Windows Server 2003 on Intel or equivalent, 64- or 32-bit
Yes
(Requires SP2 or higher)

Yes
(Requires SP2 or higher)

No
No
No
Microsoft Windows 2000 Server on Intel or equivalent, 32-bit
Yes
(Requires SP4 or higher)

No
No
No
No
Microsoft Windows Vista on Intel or equivalent, 64- or 32-bit
Yes
No
No
No
No
Microsoft Windows XP on Intel or equivalent, 64- or 32-bit
Yes
(Requires SP2 or higher)

No
No
No
No

Supported UNIX Platforms

The following UNIX systems and platforms are supported by Reflection PKI Services Manager 1.0 or higher:

Platform
PKI 1.0 – 1.2
PKI 1.2 SP1 – SP2
PKI 1.3 – 1.3 SP1
IBM AIX 7.1 on PowerPC, 64-bit
No
Yes
Yes
IBM AIX 5.3 on PowerPC, 64- or 32-bit
Yes
No
No
HP HP-UX 11i v3 on Itanium, 64-bit
Yes
No
No
HP HP UX 11i v2 on Itanium, 64-bit
Yes
No
No
HP HP-UX 11i v2 on PA-RISC, 64- or 32-bit
Yes
No
No
HP HP-UX 11i v1 on PA-RISC, 64- or 32-bit
Yes
No
No
Novell SUSE Linux Enterprise Server 11 on Intel or equivalent, 64- or 32-bit
No
Yes
Yes
Novell SUSE Linux Enterprise Server 10 on Intel or equivalent, 64- or 32-bit
Yes
Yes
Yes
Novell SUSE Linux Enterprise Server 9 on Intel or equivalent, 64- or 32-bit
Yes
No
No
Novell SUSE Linux Enterprise Server 9 on Itanium, 64-bit
Yes
No
No
Oracle Solaris 10 on Intel or equivalent, 64- or 32-bit
Yes
Yes
Yes
Oracle Solaris 10 on SPARC V9, 64- or 32-bit
Yes
Yes
Yes
Oracle Solaris 9 on SPARC V9, 64- or 32-bit
Yes
No
No
Oracle Solaris 8 on SPARC V9, 64- or 32-bit
Yes
No
No
Red Hat Enterprise Linux 6 on Intel or equivalent, 64- or 32-bit
No
Yes
Yes
Red Hat Enterprise Linux 5 on Intel or equivalent, 64- or 32-bit
Yes
Yes
Yes
Red Hat Enterprise Linux 5 on Itanium, 64-bit
Yes
No
No
Red Hat Enterprise Linux 4 on Intel or equivalent, 64- or 32-bit
Yes
No
No
Red Hat Enterprise Linux 4 on Itanium, 64-bit
Yes
No
No

Supported Virtualization Products

PKI Services Manager is supported on the following virtualization platforms if you can run it as a guest on one of the supported operating systems listed above.

Product
PKI 1.0 -1.2 SP1
PKI 1.2 SP2
PKI 1.3 – 1.3 SP1
VMServer (ESX)
Yes
No
No
VMware vSphere Hypervisor (ESXi)
No
Yes
Yes

Console Requirements

The console provides a user interface for PKI Services Manager on Windows systems. It is not required for configuring and using PKI Services Manager. Complete support is available on all systems using the commands and configuration files described in the Reference section of the PKI Services Manager User Guide.

Requirements for running the console include:

  • PKI Services Manager must be installed on a Windows system. The console is not supported on UNIX systems.
  • The console requires a minimum display size of 800x600.

Additional Resources

Technical resources for Reflection PKI Services Manager are available on the Attachmate Support site at http://support.attachmate.com/product/?prod=PKID.

For an overview of PKI Services Manager and information about obtaining the PKI Services Manager Add-on, see Technical Note 2425.

Related Technical Notes
2425 Reflection PKI Services Manager Overview
2688 Reflection PKI Services Manager 1.3 New Features and Release Notes
2716 Which Products Include Reflection PKI Services Manager?
2762 Reflection PKI Services Manager 1.3 Service Pack 1 New Features and Release Notes

Did this technical note answer your question?

           



Need further help? For technical support, please contact Support.