Français · Deutsch · Italiano · 日本語 · Español Upgrading to Reflection 2011
Technical Note 2508
Last Reviewed 12-Oct-2012
Applies To
Reflection for IBM 2011
Reflection for UNIX and OpenVMS 2011
Reflection Standard Suite 2011
Summary

This technical note describes recommendations to consider when upgrading to Reflection 2011.

For a list of new features and release notes for Reflection 2011 R3, see Technical Note 2631.

This document is organized into the following topics:

Before You Upgrade to Reflection 2011

Carefully review the warnings in this section before upgrading to Reflection 2011 or an evaluation copy of Reflection 2011.

  • Reflection 2011 uses the Microsoft Windows Installer (MSI) technology, which detects and automatically upgrades earlier versions of EXTRA! or Reflection (listed in the following section) that were deployed using MSI.
  • You cannot retain an earlier version of EXTRA! or Reflection when you install Reflection 2011, even if EXTRA! or Reflection is installed in a different location. The earlier version will be removed by the upgrade. Note: User-created configuration files will be preserved.
  • Removing Reflection 2011 will not restore the previous version of EXTRA! or Reflection.
  • If you plan to return to a custom installation of EXTRA! or Reflection, you must save the EXTRA! or Reflection settings and customizations prior to installing Reflection 2011.
  • To return to earlier versions of EXTRA! or Reflection, you must uninstall Reflection 2011 from the workstation and then reinstall EXTRA! or Reflection. EXTRA! or Reflection settings and customizations can be reapplied only if they were saved prior to the Reflection 2011 upgrade.
  • Reflection Command Language (RCL), Reflection Basic (RB), EXTRA! Basic (EB), and Visual Basic for Applications (VBA) macros are all supported in Reflection 2011. No conversion is needed during the upgrade.
  • Reflection Enterprise Suite 2011 includes Reflection Standard Suite 2011 (to which this note applies) and Reflection for the Web 2011. For information about upgrading to Reflection for the Web 2011, see Technical Note 2349.

Upgrading from Earlier Versions of Reflection or EXTRA!

Reflection 2011 products include:

Reflection for UNIX and OpenVMS 2011
Reflection for IBM 2011
Reflection Standard Suite 2011
Reflection Enterprise Suite 2011

Reflection 2011 products upgrade the following products:

EXTRA! X-treme version 8.0 – 9.x
EXTRA! 6530 Client Option 7.x – 9.x
myEXTRA! Enterprise version 7.0
myEXTRA! version 7.x
EXTRA! Enterprise 2000
Reflection for UNIX and OpenVMS 2008
Reflection for IBM 2008
Reflection Standard Suite 2008
Reflection for NonStop 2008 Add-On
Reflection for IBM 2007
Reflection for IBM version 8.0 – 14.x
Reflection for UNIX and OpenVMS version 8.0 – 14.x
Reflection for the Multi-Host Enterprise Standard Edition, version 8.0 – 14.x
Reflection for the Multi-Host Enterprise Professional Edition, version 8.0 – 14.x
An evaluation copy of Reflection 2011

Note the following:

  • Reflection Standard Suite 2011 will upgrade Reflection for the Multi-Host Professional Edition 14.x. Note: You will no longer have HP emulation after upgrading.
  • Reflection 2007 is automatically removed when you upgrade. EXTRA! and the other Reflection products (listed above) are automatically removed when you upgrade using setup.exe. If you upgrade these products by deploying the .msi file directly, you will get a message telling you to uninstall the older software first.
  • Reflection 2011 products will detect and remove EXTRA! 6530 Client Option 7.x – 9.x and Reflection for NonStop 2008 Add-On. You must also install Reflection for NonStop 2011 Add-On if you require connectivity to NonStop/Tandem systems. For more information about Reflection for NonStop 2011 Add-On, see Technical Note 2512.

Supported Legacy Files

For a list of the legacy Reflection and EXTRA! files supported in Reflection 2011, see Technical Note 2193.

Reflection 2011 Will Not Install on Workstations Where These Attachmate Products Are Already Installed

Reflection 2011 products will not install on a machine that has any of these Reflection products already installed:

INFOConnect Enterprise Edition version 7.0 – 9.0
Reflection X version 8.0 – 14.x
Reflection Suite for X version 8.0 – 14.x
Reflection for HP with NS/VT version 8.0 – 14.x
Reflection for the Multi-Host Enterprise Professional Edition, version 8.0 – 14.x*

* Reflection for IBM 2011 and Reflection for UNIX and OpenVMS 2011 will not install on a machine where Reflection for the Multi-Host Enterprise Professional Edition is installed. Reflection Standard Suite 2011, however, will upgrade Reflection for the Multi-Host Professional Edition 14.x. Note: You will no longer have HP emulation after upgrading.

Reflection 2011 will display a message indicating that you must close the Reflection 2011 install, remove the previously installed product (listed above), and then run the Reflection 2011 installation program again.

For example, if you run the Reflection Standard Suite 2011 installation on a machine where Reflection Suite for X version 14.1 is already installed, you will receive the following message.

Note: Reflection 2011 products do not currently provide connectivity to HP hosts or Unisys mainframes, nor does it provide PC X server functionality, so if you require connectivity to any of these resources, you should install Reflection 2011 to a separate machine and leave the previously installed Reflection product installed on your current machine. Support for Unisys systems is planned for future releases.

Installing and Deploying

For information about installing and deploying Reflection 2011, see the Installation and Deployment Guide (available on the Reflection 2011 Documentation page on the Support site): http://docs.attachmate.com/reflection/2011/r3/deploy/deploymentguide.pdf.

If Deploying the Reflection 2011 Installer Package (*.msi) File Directly

If you are deploying the Reflection 2011 installer package (*.msi) file directly (for example, if you are using a third-party tool to deploy the update), note the following:

  • You must first manually uninstall any earlier versions of Reflection or EXTRA! from the workstation where you want to install Reflection 2011. (If you upgrade these products by deploying the .msi file directly and have not removed the earlier version, a message displays telling you to uninstall the older software first.)
  • You must first deploy the appropriate .NET Framework version. as a separate package to workstations where it is not installed. (See Microsoft .NET Framework Must Be Installed on Windows XP Workstations.)
  • Windows Installer 3.1 will not be installed automatically on Windows XP. See Microsoft Windows Installer 3.1 and Windows XP.
  • When installing Reflection 2011 R2 or higher using *.msi, if you want VBA support, the VBA-specific files must be installed separately. The VBA *.msi files are in the installation image, located at \Prerequisites\VB65\. Both VBAOF11.msi and a language-specific msi VBAOF11I.msi (located in \Prerequisites\VB65\10nn\VBAOF11l.msi) must be installed. See Technical Note 2605 for troubleshooting information.

Removing Earlier Versions of Reflection or EXTRA!

Running the Reflection 2011 setup.exe will automatically remove earlier versions of Reflection or EXTRA! (listed in the Upgrading from Earlier Versions of Reflection or EXTRA! section); this is a required step. If, however, you are deploying the Reflection 2011 installer package (*.msi) file directly (for example, if you are using a third-party tool to deploy the update), you must first manually uninstall the earlier version Reflection or EXTRA!.

The command to manually remove Reflection or EXTRA! varies depending on your product and version.

Microsoft .NET Framework Must Be Installed on Windows XP Workstations

Microsoft .NET Framework requirements depend on the Reflection 2011 version:

  • Reflection 2011 R2 requires Microsoft .NET Framework 4.0 Runtime (or higher).
  • Reflection 2011 R1 requires Microsoft .NET Framework 3.0 SP1 Runtime (or higher).

Both 32-bit and 64-bit versions of this prerequisite software are distributed with Reflection 2011.

Note: The .NET Framework is included in Windows Vista and Windows 7. Be sure that you have the .NET Framework version required by the version of Reflection 2011.

If you use the Reflection 2011 installer (setup.exe), the wizard determines whether the system has the .NET Framework, and automatically installs it if necessary.

If you are deploying Reflection 2011 installer package (*.msi) file directly, you must first deploy the appropriate .NET Framework version as a separate package to workstations where it is not installed.

Microsoft Windows Installer 3.1 and Windows XP

The Microsoft Windows Installer (MSI) version 3.1 is distributed with Reflection 2011. This applies to Windows XP only. (Windows 7, Windows Vista, and Windows Server 2003 Service Pack 1 already include a later version.) For more information, see the "Hardware and Software Requirements section of the Installation and Deployment Guide (http://docs.attachmate.com/reflection/2011/r3/deploy/deploymentguide.pdf).

Additional Resources

The Installation and Deployment Guide for Reflection 2011 is available online at http://docs.attachmate.com/Reflection/2011/r3/deploy/deploymentguide.pdf.

The product guide for Reflection 2011 is available in the product and online at http://docs.attachmate.com/Reflection/2011/r3/help/en/user-html/.

For information about how to contact Technical Support, see http://support.attachmate.com/contact/.

Related Technical Notes
2193 Supported Legacy Reflection, EXTRA!, and KEA! Files in Reflection 2014 and 2011
2349 Upgrading to Reflection for the Web 2014
2512 Reflection for NonStop 2011 Add-On Release Notes
2571 Reflection 2011 R2 New Features and Release Notes
2605 Reflection 2014 or 2011 R2 - R3 Error: "Error initializing VBA components."
2631 Reflection 2011 R3 New Features and Release Notes

Did this technical note answer your question?

           



Need further help? For technical support, please contact Support.