Error "Internal Error Unable to Load or Call External DLL" Occurs when Uninstalling EXTRA! or RALLY! 6.5

  • 7021788
  • 23-Jan-2009
  • 02-Mar-2018

Environment

EXTRA! Personal Client version 6.5
RALLY! for AS/400 version 6.5
Microsoft Windows 2000 Server with Terminal Services
Microsoft Windows 2000 Professional

Situation

When attempting to uninstall EXTRA! Personal Client 6.5 or RALLY! 6.5 through Add/Remove Programs, you may receive the following error: "Internal Error Unable to Load or Call External DLL."

Resolution

In order to uninstall EXTRA! Personal Client 6.5 or RALLY! 6.5, you can do one of the following:

Install EXTRA!/RALLY! 6.5 Service Pack 2

EXTRA!/RALLY! 6.5 Service Pack 2 includes a fix for the error message, "Internal error, unable to load or call external DLL," when attempting to uninstall from Add/Remove Programs.

Follow these steps to download and install Service Pack 2.

  1. Close all other applications on your desktop to ensure that no system-wide shared files are in use by the operating system during setup.

Note: If you have Windows NT 4.0, ensure that all Control Panel programs are closed or the installation may fail. Setup will not install if any EXTRA!-related programs are running.

  1. Download the file, ESP2.EXE, from the Attachmate Download Library to a temporary directory.

Note: Make sure that the environment variable TEMP is assigned to a directory with read/write access and that there is at least 1.5 MB of available space.

  1. Run the executable to unpack files.
  2. After the files are unpacked, run SETUP.EXE.

Important: If you have EXTRA!/RALLY! 6.5 Server and Client installed to the same machine, the Service Pack installation must be run twice, once to update the Server, and once to update the Client.

The Service Pack updates the Server installation (by default). To update the Client installation (when both the Server and Client installations reside on the same machine) run SETUP.EXE from the command line using the CLIENT parameter (SETUP.EXE CLIENT) which updates the client files for that system.

Note: When the Service Pack is installed, Setup makes backup copies of the original EXTRA! files that are updated. These backup files are copied to a directory called 65BACKUP, located in the directory where EXTRA! is installed.

  1. After Service Pack 2 is installed, you can uninstall EXTRA! Personal Client 6.5 and then you can also uninstall EXTRA! Personal Client 6.5 Service Pack 2.

Replace the Missing File and Modify the Registry

Follow these steps to download and replace the missing uninstall file.

Warning: Proceed with extreme caution when editing the Windows Registry. It is critical to back up the Registry before you proceed. For full details and warnings regarding editing the Windows Registry, see Microsoft Article 256986: http://support.microsoft.com/default.aspx?scid=kb;en-us;256986. Use Registry Editor at your own risk.

  1. Download the file, UNINSTNT.zip, from the Attachmate Download Library. Unzip the file. (It contains the UNINSTNT.dll file.)
  2. Copy the file, UNINSTNT.DLL, into the EXTRA! directory. By default, this is located in C:\Program Files\E!PC.
  3. Open Regedit.exe to edit the Registry. Go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\EXTRA! Personal Client 32-bit.
  4. Find the key named UninstallString.
  5. Open the key to edit the Value data to reflect the file, UNINSTNT.DLL, rather than UNINST95.DLL.
  6. Click OK and refresh the screen.
  7. Copy the updated string and go to Start > Run and paste the string into the Open: field; by default the string should be: C:\WINDOWS\IsUninst.exe -f"C:\Program Files\E!PC\DeIsL1.isu" -C"C:\Program Files\E!PC\uninstnt.dll" -m"Attachmate_Uninstall".
  8. Click OK and the Uninstall will start.

Or, Manually Remove the Product(s)

Alternately, you can manually remove EXTRA! Personal Client 6.5 or RALLY! 6.5 by following these steps.

Warning: Proceed with extreme caution when editing the Windows Registry. It is critical to back up the Registry before you proceed. For full details and warnings regarding editing the Windows Registry, see Microsoft Article 256986: http://support.microsoft.com/default.aspx?scid=kb;en-us;256986. Use Registry Editor at your own risk.

  1. From Control Panel, click Add or Remove Programs.
  2. Select RALLY! or EXTRA! and click Change to open the package and change which components or features are installed.
  3. The "Run Installation Program" dialog box opens prompting for the path of the uninstall program.

Note: Do not enter anything on the command line, just click OK.

  1. Another dialog box opens, "Uninstaller Error." There is an option to remove RALLY! or EXTRA! from the Add / Remove programs list. Click Yes.

Note: This will not uninstall the program.

  1. Remove the program group RALLY! or EXTRA! from the Program Files directory.
  2. Open Regedit.exe to edit the Registry. Remove the following keys:
My Computer\HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\XXXXXXXXX (XXXXXXXXXX)
My Computer\HKEY_CURRENT_USER\Software\Attachmate
My Computer\HKEY_LOCAL_MACHINE\Software\Attachmate.

Note: XXXXXXXXX (XXXXXXXXXX) represents the installed Attachmate software entry.

  1. Exit the Registry. Your edits are automatically saved.

Cause

When EXTRA! Personal Client 6.5 or RALLY! 6.5 installs, there is a missing file and that file is called at the time of uninstall. In addition, when you look in the registry at the uninstall string, it is incorrect as well.

Additional Information

Legacy KB ID

This article was originally published as Attachmate Technical Note 2409.
This information was originally published as Attachmate SupportWeb solution 1.0.4918259.2947294.