Troubleshooting Reflection for the Web Errors Using the Java Console
Technical Note 1433
Last Reviewed 30-May-2008
Applies To
Reflection for the Web 2011 (All Editions)
Reflection for the Web 2008 (All Editions)
Summary

This technical note explains how to view the Java Console in popularly used browsers. The Java Console is a useful tool for isolating problems that occur with Reflection for the Web sessions.

Viewing the Java Console Log

Follow the steps for your browser to view errors in the Java console:

Internet Explorer for Windows

Internet Explorer for Windows can use either the Microsoft Virtual Machine or the Sun Java Plug-In 1.4 or higher as the default virtual machine for Java applets.

To view your Java console, follow the steps in the section below that applies to your Java virtual machine.

Microsoft Virtual Machine

  1. On the Tools menu, click Internet Options.
  2. Click the Advanced tab.
  3. Scroll down to the section titled Microsoft VM.
  4. Select "Java console enabled" and "Java logging enabled."
  5. Restart your browser.
  6. Repeat the steps that caused the problem.
  7. On the View menu, click Java Console. Note any error messages that appear. You can copy the contents of the console by selecting the text with your mouse and pressing Ctrl+C on your keyboard.

Sun Java Plug-In 1.4 or Higher

  1. Click Tools > Sun Java Console.
  2. Repeat the steps that caused the problem. Note any error messages that appear in the Java Console. To copy the console, click the Copy button in the console window.

Note: Alternately, you can open the Java console by double-clicking the Java Plug-in icon in the Windows system tray while the Reflection for the Web session is running.

Firefox for Windows

  1. After launching Reflection for the Web, look for the Java Console icon in the notification area (system tray) of the Taskbar. (This is typically located in the right bottom corner of your Windows desktop.) Right-click the Sun Java icon and select Open Console.
  2. Repeat the steps that caused the problem. Note any error messages that appear in the Java Console. To copy the console, click the Copy button in the console window.

Netscape 7

  1. Start the Java Console. On the Tools menu, click Web Development > Java Console.
  2. Repeat the steps that caused the problem. Note any error messages that appear in the Java Console. To copy the console, click the Copy button in the console window.

Safari and Mozilla Firefox for Macintosh

  1. Open the Application directory under Utilities. Select Java. Then select Java 1.x.xx Plug-in Settings and enable “Use Java Console.”
  2. Perform the steps that caused the problem.
  3. Note any error messages that appear in the Java Console. To copy the console, click the Copy All button in the console window.

Troubleshooting Resources

The errors saved in the Java Console usually include limited troubleshooting information. The Troubleshooting section of the Administrative WebStation contains a list of known issues. In addition, technical notes are created and updated as new issues are identified. For a list of Reflection for the Web technical notes, see Technical Note 9988.

Contacting Technical Support

If you are unable to solve the problem using the information in the Java Console and the troubleshooting resources listed above, please contact Attachmate Technical Support. For contact information, see http://support.attachmate.com/contact/.

Related Technical Notes
1674 Reflection for the Web and Java Virtual Machines
9988 Reflection for the Web Technical Notes

Did this technical note answer your question?

           



Need further help? For technical support, please contact Support.