Supported Platforms and Systems Requirements for Verastream Host Integrator
Technical Note 10030
Last Reviewed 12-Mar-2015
Applies To
Verastream Host Integrator version 7.1 or higher
Summary

This technical note describes systems requirements and platforms that are supported by Verastream Host Integrator (VHI).

This technical note is organized into the following sections:

Server Requirements

The following platforms are supported by the Host Integrator runtime server services (Session Server, Management Server, and Host Emulator).

Platform
VHI 7.7
VHI 7.6 or 7.6 SP1
VHI 7.5 SP1
VHI 7.5
VHI 7.1 SP2
VHI 7.1 or 7.1 SP1
Microsoft Windows Server 2012 (on Intel or equivalent, 64-bit)
Yes, R1 or R2
Yes
Yes
Yes
Not supported
Not supported
Microsoft Windows Server 2008 Standard Edition (on Intel or equivalent)
Yes, R2, 64-bit only
Yes, R2, 64-bit only
Yes, R1 or R2, 64-bit only
Yes, R1 or R2, 64-bit only
Yes, R1 or R2
Yes, R1 or R2
Microsoft Windows 8 (on Intel or equivalent, 64-bit)
Dev Kit only
Dev Kit only
Yes
Yes
Not supported
Not supported
Microsoft Windows 7 (on Intel or equivalent)
Dev Kit only
Dev Kit only
Yes, 64-bit only
Yes, 64-bit only
Yes
Yes
Microsoft Windows Server 2003 Standard Edition (on Intel or equivalent, 64- or 32-bit)
Not supported
Not supported
Not supported
Not supported
Yes, R1 or R2
Yes, R1 or R2
Microsoft Windows XP Professional (on Intel or equivalent)
Not supported
Not supported
Not supported
Not supported
Dev Kit only
Dev Kit only
Sun Solaris 11 (SunOS 5.11) on SPARC
Yes***
Yes***
Yes***
Yes***
Yes
Not supported
Sun Solaris 10 (SunOS 5.10) on SPARC
Yes
Yes
Yes
Yes
Yes
Yes
Sun Solaris 9 (SunOS 5.9) on SPARC
Not supported
Not supported
Not supported
Not supported
Not supported
Yes
Red Hat Enterprise Linux 7 (RHEL7) on Intel, 64-bit
Yes
Not tested
Not tested
Not tested
Not tested
Not tested
Red Hat Enterprise Linux 6 (RHEL6) on Intel, 64- or 32-bit
Yes, 64-bit only
Yes, 64-bit only
Yes
Yes
Yes
Yes
Red Hat Enterprise Linux 6 on IBM System z
Yes
Yes
Yes
Not supported
Not supported
Not supported
SUSE Linux Enterprise Server 12 on Intel 64-bit
Yes
Not tested
Not tested
Not tested
Not tested
Not tested
SUSE Linux Enterprise Server 12 on IBM System z
Yes
Not tested
Not tested
Not supported
Not supported
Not supported
SUSE Linux Enterprise Server 11 on IBM System z
Yes
Yes
Yes, SP2*
Not supported
Not supported
Not supported
SUSE Linux Enterprise 11 on Intel x86
Yes, 64-bit only
Yes, 64-bit only
Yes, SP1*
Yes, SP1*
Yes, SP1*
Yes, SP1*
SUSE Linux Enterprise 10 on Intel x86 or equivalent
Not supported
Not supported
Not supported
Not supported
Not tested
Not tested
IBM AIX 7.x on IBM System p
Yes
Yes
Yes
Yes
Yes**
Yes**
IBM AIX 6.x on IBM PowerPC
Yes
Yes
Yes
Yes
Yes**
Yes**
IBM AIX 5.3.0.30 on IBM PowerPC 604e
Not supported
Not supported
Not supported
Not supported
Yes**
Yes**

*The SP notation indicates a supported minimum service pack level for the operating system.

**IBM AIX is supported in VHI version 7.1.1140 (Service Pack 1) or higher, but not 7.1.221 (original 7.1 release). On the IBM AIX 6.1 platform, Technology Level 6100-04 Service Pack 3 (TL 6100-04 SP3) is recommended. FIPS 140-2 validated encryption is not supported on the AIX platform.

***On Solaris 11, to avoid Administrative Console connection issues, see also Technical Note 10097 regarding modifications to the /etc/hosts file.

Minimum memory, processor speed, and disk space requirements are described in the Installation Guide (available at http://support.attachmate.com/manuals/vhi.html). For best performance, your physical memory should exceed minimum requirements (recommended minimum 1 GB of RAM, and an additional 128 MB of RAM for each 100 concurrent sessions).

Virtualization Support

Verastream Host Integrator server components are supported on any virtualization platform that meets the stated system requirements, including memory, processor speed, and disk space. VHI has been tested on VMware Workstation/Player and VMware Virtual Lab.

Development Kit Requirements

The following platforms are supported by the Design Tool, Web Builder, and Administrative Console applications.

Platforms
VHI 7.7
VHI 7.6 or 7.6 SP1
VHI 7.5 or 7.5 SP1
VHI 7.1.x
Microsoft Windows 8.1
Yes
Yes
No
No
Microsoft Windows 8 (on Intel or equivalent, 64-bit)
Yes
Yes
Yes
No
Microsoft Windows 7 (on Intel or equivalent)
Yes, 64-bit only
Yes, 64-bit only
Yes, 64-bit only
Yes
Microsoft Windows Server 2012 (on Intel or equivalent, 64-bit)
Yes, R1 or R2
Yes
Yes
No
Microsoft Windows Server 2008 (on Intel or equivalent)
Yes, R2, 64-bit only
Yes, R2, 64-bit only
Yes, R2, 64-bit only
Yes, R1 or R2
Microsoft Windows Vista - Business, Enterprise, or Ultimate Editions (on Intel or equivalent, 64- or 32-bit)
Not supported
Not supported
Not supported
Yes**
Microsoft Windows Server 2003 Standard Edition (on Intel or equivalent, 64- or 32-bit)
Not supported
Not supported
Not supported
Yes, R1 or R2
Microsoft Windows XP Professional (on Intel or equivalent, 64- or 32-bit)
Not supported
Not supported
Not supported
Yes, SP3*

*The SP notation indicates a supported minimum service pack level for the operating system.

**When running on Windows Vista with User Account Control enabled, administrative privileges are required. To configure Windows Vista for Web Builder projects, see Technical Note 10081.

To use the Design Tool application, a minimum video resolution of 1024x768 is required.

Minimum memory and disk space requirements are described in the Installation Guide (available at http://support.attachmate.com/manuals/vhi.html).

64-Bit Support

The following information clarifies VHI support for 64-bit environments:

  • Beginning in version 7.6, only 64-bit is supported for all platforms (Windows and Linux/UNIX).
  • Beginning in version 7.5, Windows Server Kit and Development Kit are 64-bit only. Note: This version cannot be installed on 32-bit Windows platforms. If you still need server support for 32-bit Windows, please install version 7.1 SP2 in your environment. However, if you just need a 32-bit COM connector API for 32-bit client applications (such as Microsoft Excel), a separate 32-bit ComConnector.msi installer is available beginning in version 7.6 SP1.
  • In previous versions (Windows pre-7.5 or Linux/UNIX pre-7.6), VHI server runtime components support 64-bit operating system environments running as a 32-bit application.
  • Connectors support 64-bit client applications:
    • The Java Connector is designed to work on any operating system that supports Java 2 Platform, Standard Edition (J2SE) or Enterprise Edition (J2EE), including 64-bit operating systems. Java Connector works with either a 64-bit or 32-bit JRE. You can use the JRE/JDK installed with VHI or a separate installation (see Java Requirements below).
    • The .NET Connector (version 6.6 and higher) supports 64-bit .NET Framework on Windows x64 platforms. (If .NET Framework is not detected by the VHI 7.x installer, it is automatically installed, including 64-bit .NET Framework on x64 platforms.)
    • The C/C++ Connector API is either 64-bit or 32-bit (same as the installed product), depending on your VHI version and platform.
  • Model event handlers (optional scripting to customize Session Server behavior) execute in the script server engine as follows:
    • For Java event handlers, the script server runs the same as the installed product, either 64- or 32-bit.
    • For .NET event handlers (version 7.0 or higher), the script server will automatically execute with the 64-bit Common Language Runtime on a 64-bit Windows operating system.
  • If you are generating a .NET web application project with Web Builder that will be deployed to Microsoft IIS in 64-bit mode, note that Web Builder must be configured to use 64-bit .NET Framework. For more information, see Technical Note 10085.

IPv6 Support

The following information applies to IPv6 network environments:

  • VHI uses IPv4 by default. In VHI version 7.5 or higher, you can enable IPv6 support. See page 6 of the Installation Guide at http://docs2.attachmate.com/verastream/vhi/7.7/en/topic/com.attachmate.vhi.help/install_guide.pdf. Note: If you enable IPv6, it must be enabled for all components in your installation environment. Also, when you upgrade to a later version (hotfix or major release) in the future, be aware that the edited .conf files may revert to defaults.
  • For VHI version 7.1.x and earlier, your system network configuration must have IPv4 also enabled (in addition to IPv6).

Web Browser Requirements

In version 7.0 and higher, a web browser is used to run web applications generated with the Web Builder tool. In the following table, "Yes" indicates an officially tested and supported web browser version (although others may also work).

Web Browser Version
VHI 7.7
VHI 7.6 or 7.6 SP1
VHI 7.5 or 7.5 SP1
VHI 7.1 SP2
VHI 7.1 or 7.1 SP1
Microsoft Internet Explorer 9.0 or higher
Yes
Yes
Yes
Yes
Yes
Microsoft Internet Explorer 8.0
Not supported
Not supported
Not supported
Limited testing
Yes
Microsoft Internet Explorer 7.0
Not supported
Not supported
Not supported
Not tested
Success reported
 
 
 
 
 
 
Mozilla Firefox
Yes
Yes
Yes, version 14 or higher
Yes, version 8 or higher
Yes, version 3.x
Google Chrome
Yes
Yes
Yes
Yes
Yes
Apple Safari
Yes
Yes
Yes
Not tested
Not tested
Opera
Yes
Yes
Not tested
Not tested
Not tested

Java Requirements

Host Integrator installs and supports the following Java Development Kit (JDK) versions:

VHI Version
JRE Version
Subdirectory
7.7
1.7.0_75
Windows: Attachmate\Verastream\java\jdk1.7.0_75-64\jre\bin
Solaris/Linux: attachmate/verastream/java/jdk1.7.0_75_64/jre/bin
7.6 SP1
1.7.0_55
Windows: Attachmate\Verastream\java\jdk1.7.0_55-64\jre\bin
Solaris/Linux: attachmate/verastream/java/jdk1.7.0_55_64/jre/bin
7.6
1.7.0_45
Windows: Attachmate\Verastream\java\jdk1.7.0_45-64\jre\bin
Solaris/Linux: attachmate/verastream/java/jdk1.7.0_45_64/jre/bin
7.5.1030 (SP1)
1.7.0_21
Windows: Attachmate\Verastream\java\jdk1.7.0_21-64\jre\bin
Solaris/Linux: attachmate/verastream/java/jdk1.7.0_21/jre/bin
7.5
1.7.0_09
Windows: Attachmate\Verastream\java\jdk1.7.0_09-64\jre\bin
Solaris/Linux: attachmate/verastream/java/jdk1.7.0_09/jre/bin
7.1.2026 (SP2)
1.6.0_29
attachmate/verastream/java/jdk1.6.0_29/jre/bin
7.1.1142 (SP1)
1.6.0_26
attachmate/verastream/java/jdk1.6.0_26/jre/bin
7.1
1.6.0_24
attachmate/verastream/java/jdk1.6.0_24/jre/bin
7.0
1.6.0_16
attachmate/verastream/java/jdk1.6.0_16/jre/bin

Releases are not officially re-tested with later Java versions.

On IBM platforms (Linux on System z or AIX), VHI 7.0 and higher does not install Java due to redistribution restrictions. Before installing VHI 7.x on IBM systems, you must install IBM's JDK version as directed in the Installation Guide for your VHI version. The VHI interactive installer will prompt for your JDK directory path, typically /usr/java7. Note: For VHI version 7.6 or higher, install 64-bit Java. For VHI version 7.5.x and earlier, install 32-bit Java. If you install the wrong Java, VHI services will not start.

For more information about how Java is used in Attachmate products, including VHI, see Technical Note 2600.

Development Environment Requirements

To develop a client application (or modify an application generated with Web Builder) or model event handler scripting, you need an appropriate development environment, in addition to Client Connector Requirements.

To develop a…
You need…
.NET application, or model .NET event handlers:
Note: To link to .NET data types from the VHI MSDN-style help, or generate .NET project types:

Microsoft Visual Studio*

Microsoft .NET Framework SDK

Visual Basic or C++ application:
Microsoft Visual Studio, version 6.0 or higher
ASP or ASP .NET web-based application or Web Service:
Microsoft IIS web server is required
C/C++ application:
API source files are located in the include subdirectory
Java application, or model Java event handlers:
a Java IDE is recommended

*Beginning in VHI version 6.0, Web Builder can generate .NET projects (web applications or class library objects) for .NET Framework 2.0 and Visual Studio 2005. When the project is opened with a newer version of Visual Studio (2008 or 2010), it converts the generated project. (Higher .NET Framework versions 3.0 through 4.5 co-exist with 2.0 due to side-by-side framework compatibility.)

Client Connector Requirements

Depending on the connector technology used, the client application you develop has the following runtime requirements.

SOAP/REST Web Services

For information about web services support, see http://docs2.attachmate.com/verastream/vhi/7.7/en/topic/com.attachmate.vhi.help/html/reference/web_services.xhtml. Note: REST is supported beginning in version 7.7.

.NET Connector

For your Windows client application to use the VHI .NET Connector, Microsoft .NET Framework 2.0 must be installed. (Higher .NET Framework versions 3.0 through 4.5 co-exist with 2.0 due to side-by-side framework compatibility.)

Beginning in version 6.6, the .NET Connector (pure C# managed code) can be deployed and managed as part of your .NET client application code. In versions 6.0 and 6.5, the .NET connector must be installed using Setup (either Development Kit or Windows Server Kit) and relies upon the COM connector.

COM Connector

For your Windows (ASP, VB, VBScript, or C++) client application to use the VHI COM Connector, install the AppConn COM Connector component using Setup in VHI Development Kit or Server Kit for Windows. This will properly install and register the appconncom.dll (version 6.5 or higher) or appconn.dll (version 6.0 or earlier), and xerces*.dll files.

Beginning in version 7.5, Windows Server Kit and Development Kit are 64-bit only. However, beginning in version 7.6 SP1, a separate 32-bit COM Connector installer is available to provide compatibility for 32-bit client applications. For more information on running ComConnector.msi, see the Installation Guide at http://support.attachmate.com/manuals/vhi.html.

Java Connector

The VHI Java Connector is designed to work on any operating system that supports Java 2 Platform, Standard Edition (J2SE) or Enterprise Edition (J2EE), including 64-bit operating systems. For information about JRE versions that are installed and supported by Host Integrator, see Java Requirements section above.

The Java connector .jar files (apptrieve.jar, vhiprop.jar, wcp.jar) are installed with either Development Kit or Server Kit (to the Host Integrator lib/java subdirectory) and must be added to your CLASSPATH.

C Connector API

On Windows, the VHI C Connector is included in installation of the VHI COM Connector. The appconn.dll and xerces-c_3_1.dll files are installed in your Windows System32 directory. Beginning in version 7.0, for encryption support, the %VHI_ROOT%\bin directory should be added to your system PATH environment variable (Control Panel > System > Advanced > Environment Variables > System variables).

On Linux or Solaris, the directory containing libappconn and libxerces-c-3.1.so files must be added to your LD_LIBRARY_PATH environment variable, On AIX, the directory containing libappconn and libxerces-c-3.1.a must be added to your LIBPATH environment variable. The Server Kit installs these files to the <VHI>/lib directory. Beginning in version 7.0, libssccm.so.2.0.40 and libssccm.2.0.40.cksum are also installed to /usr/lib. Beginning in version 7.6 SP1, libssh2 is used for SSH support.

Related Technical Notes
2600 Java and Attachmate Products
10077 Web Builder String Index Error on .NET Framework 3.5
10081 Web Builder Error "Failed to exec adsutil"
10085 IIS 64-Bit Mode Error When Building Verastream .NET Web Application Project
40999 Verastream Host Integrator Technical Notes

Did this technical note answer your question?

           



Need further help? For technical support, please contact Support.