How To Install the Synapta Client when a Java SDK has not been registered (in the Registry)
Technical Note USA11983Created 10-Nov-2005Applies To
Synapta Services Builders for 3270 & 5250
Goal
How To Install the Synapta Client when a Java SDK has not been registered (in the Registry)
Cause
A Java SDK has not been registered in the Windows Registry
Fix
To install the Synapta Client when a J-SDK has not been registered in the Registry, you·ll need to use the following syntax:
SC_Client_Installer.exe ·is:javahome <path to J-SDK home>
For example·
SC_Client_Installer.exe ·is:javahome c:\progra~1\attach~1\SysTools\j2sdk1.4.2_02
SC_Client_Installer.exe ·is:javahome ·c:\program files\attachmate\SysTools\j2sdk1.4.2_02·
Items to note:
· Pass the Java root directory to the ·javahome· parameter (not /bin or /bin/java.exe)
· You need not install the Client components on a machine where Designer Studio is already installed. This is because Designer Studio already includes all of the Client components (JARs, Proxy Service, and MCS Agent). In fact, installing the Client over an existing Designer or Runtime installation can actually damage the existing installation by overwriting the screen.properties file.
· The ·SC_ProxySvc_Installer.exe· Client installer is a superset of the ·SC_Client_Installer.exe·. Specifically:
SC_Client_Installer.exe includes:
· Client JARs (ScreenTaskClient, MetaData, Common, Util, mcs-rpc, xerces, xalan, xml-apis, mcsagent)
· MCSServiceAgent
· Configuration files (screen.properties & agent.properties)
SC_ProxySvc_Installer.exe includes:
· All of the above
· ScreenConnectorProxyService